Author Topic: Kenwood TS-520 repair notes  (Read 3863 times)

0 Members and 1 Guest are viewing this topic.

Offline The Radio Shop

  • Administrator
  • Hero Member
  • *****
  • Posts: 6109
  • Karma: +322/-2
    • View Profile
Kenwood TS-520 repair notes
« on: February 10, 2017, 12:15:31 PM »
I am starting this thread for the repair of a ts-520SE.
More to come
Buddy kc4umo

Offline k7rmj

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +4/-0
    • View Profile
Re: Kenwood TS-520 repair notes
« Reply #1 on: February 10, 2017, 06:01:00 PM »
That is great news, Buddy. The TS-520 and I are old friends. I remember when they first came out. I also really like the Yaesu FT-101 series (hint-hint) which was the competition for the TS-520 radios.

Really looking forward to your posts on this.

73 DE K7RMJ  Frank


Offline The Radio Shop

  • Administrator
  • Hero Member
  • *****
  • Posts: 6109
  • Karma: +322/-2
    • View Profile
Re: Kenwood TS-520 repair notes
« Reply #2 on: February 13, 2017, 04:20:39 PM »
No problem Frank. It will be fun.
I will be posting more on this later this week.
Buddy kc4umo

Offline The Radio Shop

  • Administrator
  • Hero Member
  • *****
  • Posts: 6109
  • Karma: +322/-2
    • View Profile
Re: Kenwood TS-520 repair notes
« Reply #3 on: February 20, 2017, 02:42:07 PM »
This is what happens when the connector breaks and shorts the pins on the VFO cable. Below of burnt traces on the external VFO board.
Buddy kc4umo

Offline BZimm

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Kenwood TS-520 repair notes
« Reply #4 on: April 30, 2021, 09:31:04 AM »
Hi Buddy,
Are you still active here? I enjoyed your videos on repairing the 520SE. I recently acquired one that seems to be in pretty good shape, but the radio seems to have similar issues to what you fixed in your videos. I'm just starting to look into it and wondered if you were still doing videos like this somewhere else. It's helpful to see how you do the troubleshooting and repairs.
Hope you are well,
Bzimm