Author Topic: Howdy from North Texas  (Read 50 times)

0 Members and 1 Guest are viewing this topic.

Offline KI5GKD

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Howdy from North Texas
« on: November 16, 2019, 10:56:32 PM »
I would like to thank the admin for the great Ts-520 videos.  After watching them I was able to get my "new" 520SE working this morning about an hour after FedEx left it on the porch!

I originally had a Novice ticket in the late 60s and never was able to get code speed over 10 WPM so it lapsed.  Fast forward to 2019 and I passed my General test a couple months ago so I am trying to pick back up where I left off. 

Justin B.
KI5GKD
Justin B.
KI5GKD
Yaesu FT-707, w/FC-707
Kenwood TS-520SE
ICOM IC-2300H

Offline The Radio Shop

  • Administrator
  • Hero Member
  • *****
  • Posts: 6091
  • Karma: +321/-2
    • View Profile
Re: Howdy from North Texas
« Reply #1 on: November 18, 2019, 05:03:54 AM »
Hi Justin,
Welcome to the forums.
Great to hear you got the 520 working. Good for you.

Buddy
Buddy kc4umo

Offline KI5GKD

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Howdy from North Texas
« Reply #2 on: November 18, 2019, 09:48:50 PM »
It was bought on-line with Receives OK bu no transmit.  I found when I got it that sometimes if I jiggled one of the switches the VFO light would go out so I took off the covers and went to town with the DeOxit and it was up and running in no time.  I think the receiver is better than my Yaesu FT-707.

I would probably still be working on it without your videos!
Justin B.
KI5GKD
Yaesu FT-707, w/FC-707
Kenwood TS-520SE
ICOM IC-2300H